RESOLVED: US8 Production - WorkForce Suite T&A - Service Disruption

Incident Report for WorkForce Software US8

Resolved

RESOLVED: We are pleased to report that the service disruption has been resolved. Our services are now fully operational. We thank you for your patience during this time and sincerely regret any disruptions to your operations. A detailed analysis and steps we are taking to prevent future incidents will be shared in our upcoming post incident report.
· RCA Number: RCA-1622
· Impact Start Date/Time: 15/9 14:18PM GMT & 9:18AM EST
· Impact End Date/Time: 15/9 16:15PM GMT & 11:15AM EST
· Impacted Application(s): WorkForce Suite
· Business Impact: Navigation to Timesheet or Employee Timesheet Directly.
· Issue Type: Intermittent
· Restoration Action Taken: Impacted AppNodes and cluster were restarted.
Posted Sep 15, 2025 - 15:46 UTC

Update

Update #2: WorkForce Software is currently experiencing a service disruption. Our teams are actively investigating the cause and working diligently to restore services as swiftly as possible. We recognize how vital our services are to your operations and are grateful for
your patience during this time. To keep you informed and updated, we will be providing updates in Status Hub every 1 hour based or as soon
as updated information is available until the service is fully restored.
·       RCA Number: RCA-1622
·       Impact Start Date/Time: 15/9 14:18PM GMT & 9:18 EST
·       Impacted Application(s): WorkForce Suite
·       Business Impact: Navigation to Timesheet or Employee Timesheet Directly.
·       Issue Type: Intermittent
·       Actions Underway: The team have provided a workaround which is to navigate to Timesheet or Employee Timesheet Directly.
·       ETA: Unknown
Posted Sep 15, 2025 - 14:56 UTC

Investigating

Update: WorkForce Software is currently experiencing a service disruption. Our teams are actively investigating the cause and working diligently to restore services as swiftly as possible. We recognize how vital our services are to your operations and are grateful for
your patience during this time. To keep you informed and updated, we will be providing updates in Status Hub every 1 hour based or as soon
as updated information is available until the service is fully restored.
· RCA Number: RCA-1622
· Impact Start Date/Time: 15/9 14:18PM GMT & 9:18 EST
· Impacted Application(s): WorkForce Suite
· Business Impact: WorkForce Suite customers are impacted, issues loading Suite in production.
· Issue Type: Intermittent
· Actions Underway: Technical teams have been engaged to investigate this further.
· ETA: Unknown
Posted Sep 15, 2025 - 14:36 UTC
This incident affected: US8: Phoenix AZ (OCI).